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WEB001

An in-depth exploration of ASP.NET 2.0 (Part 1)

(This lab includes an optional section on ASP.NET 2.0 User Interface Enhancements: Master Pages, Themes, and Controls which you can complete if you have enough time or want to extend your session)

Creating a Web Site

ASP.NET is loaded with new features designed to make building sophisticated Web sites easier than ever before. In this lab, you’ll build a Web site which is designed to acquaint you with some of the ASP.NET 2.0 features and provide a taste of what’s to come.

Getting Started


· Log in using the Administrator user account. The password is Pass@word1.

· Start Visual Studio 2005 by navigating to Start | All Programs | Microsoft Visual Studio 2005 | Microsoft Visual Studio.

· Select View | Solution Explorer to ensure that the Solution Explorer window is visible.

All of the exercises for this lab are in the directory C:\MSLabs\ASP.NET\Starter\<Language of choice – VB/C#>
Exercise 1
Create a Web site

In this exercise, you’ll use Visual Studio to create a new Web site. You’ll also add a pair of folders to it: one for holding images, and another for holding components.

	Tasks
	Detailed Steps

	1. Create a new Web site
	a. Start Microsoft Visual Studio.

b. Select “New Web Site” from Visual Studio’s File menu.

c. In the New Web Site dialog, choose “Visual C#” or “Visual Basic” as the project type and “Empty Web Site” as the template type. Type “C:\
MSLabs\ASP.NET\Starter\<language>\Lab1” into the Location box and click OK to create the Lab1 Web site.



	2. Add an Images folder
	d. Right-click C:\..\Lab1 in the Solution Explorer window and select “New Folder.” 

· If Solution Explorer isn’t visible, select “Solution Explorer” from the View menu to display it, or press Ctrl+Alt+L.)

e. Name the folder “Images.”
f. Right-click the Images folder in Solution Explorer and select “Add Existing Item.”
g. Navigate to the C:\MSLabs\ASP.NET\LabFiles\Images folder and select MSN.gif to add a local copy of MSN.gif to your Web site’s Images folder. 



	3. Add an App_Code folder
	h. Right-click C:\..\Lab1 in the Solution Explorer window and select “Add ASP.NET Folder ->App_Code.”
· Note that this folder named “App_Code” allows classes to be auto compiled and generally consumable within in your ASP.NET project




Exercise 2
Create a master page

In this exercise, you’ll create a master page to serve as a template for the Web site’s pages.

	Tasks
	Detailed Steps

	4. Add a master page


	i. In the Solution Explorer window, right-click C:\..\Lab1and select “Add New Item.”

j. In the Add New Item dialog, select “Master Page” and type “Site.master” into the Name box. Be sure “Place code in separate file” is checked and the appropriate language is selected in the Language box before clicking Add. 



	5. Add a table to the master page
	k. Make sure “Internet Explorer 6.0” is selected in the Target Schema for Validation drop-down list on the toolbar.

l. Click the Design button in the lower left corner of the designer window to switch to Design view.

m. Go to the Layout menu and select “Insert Table.”

n. In the Insert Table dialog, set Rows and Columns to 2. Check the Width box and enter 100%. Also check the “Cellpadding” and “Cellspacing” boxes and set both to 0. Then click OK to add the table to the master page. The table should appear above the ContentPlaceHolder control.



	6. Create a banner
	o. Drag an ASP.NET Image control from the Toolbox and drop it into the upper left cell of the table. 

· If the Toolbox window isn’t visible, select Toolbox from the View menu or press Ctrl+Alt+X.

p. Go to the Properties window and set the Image control’s ImageUrl property to “~/Images/MSN.gif”. 

· If the Properties window isn’t visible, select “Properties Window” from the View menu or press F4.

q. Also in the Properties window, set the Image control’s ImageAlign property to Middle.
r. Position the cursor just outside the left border of the table’s upper-left cell and click the grab handle to select the entire table row.
s. Go to the Properties window and set the row’s BgColor property to “#10527B”.
t. Select the next table row. Set its BgColor property to Gray and Height property to 1.
u. Select the table’s left column. Set its Width property to 100.
v. Select the table’s right column. Set its Width property to 100%. (Note the percent sign!)

w. Put the cursor in the table’s upper-right cell and type “Bookstore.”
x. Select the text you just typed. Use the Formatting toolbar to change the text to 48-point bold italic Verdana and set the Foreground color to White. 

· If the Formatting toolbar isn’t visible, select View -> Toolbars -> Formatting to make it visible.

Afterwards, you should see this in the designer:

[image: image1.png]5 sookstors |







Exercise 3
Build the main content page 

Now that the master page is complete, it’s time to build a content page. The first one you’ll build demonstrates how quickly—and with how little code—you can create a data-driven Web page with ASP.NET 2.0.

	Tasks
	Detailed Steps

	7. Add a content page


	y. Right-click C:\..\Lab1 in Solution Explorer and select “Add New Item.”

z. Select “Web Form” and name it Default.aspx. Check the “Place code in separate file” and “Select master page” boxes and make sure the appropriate language is selected in the Language box before clicking Add.
aa. In the ensuing “Select a Master Page” window, select Site.master—the master page you built in the previous exercise—and click OK.
ab. Examine the @Page directive at the top of Default.aspx. 

· Notice the MasterPageFile attribute. 

ac. Click the Design button to switch to Design view. Notice that designer shows the content inherited from the master page, but shades it to indicate that it’s not defined in the content page itself.



	8. Add a SqlDataSource control
	ad. Click the Smart Tag on upper right of content area and select “Default to Master’s Content” option on the menu. Content on the page can be Custom (default) or come from the Master. Now press the Smart Tag on upper right of content area and select “Create Custom Content”
ae. Drag a SqlDataSource control (you’ll find it in the Toolbox’s Data section) onto the page and drop it into the Content control.

af. Click “Configure Data Source” in the “SqlDataSource Tasks” menu (see below).
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ag. When the Configure Data Source dialog pops up, click the New Connection button to create a new database connection.

ah. If the Choose Data Source dialog appears, select Microsoft SQL Server in the Data source list and click Continue. 

ai. In the Add Connection dialog, type “localhost” into the “Server name” box and select “Use Windows Authentication.” Then select “Pubs” under “Select or enter a database name” and click OK.

aj. Make sure the new connection is selected in the “What data connection should your application use to connect to the database?” box. Then click Next.
ak. Make sure “Yes, save this connection as” is checked and click Next to proceed.

al. In the ensuing dialog, select “titles” in the drop-down list labeled “Name.” In the Columns box, check “title,” “price,” and “notes” as shown below. Then click Next to proceed.

am. Click Finish to finish configuring the SqlDataSource.



	9. Add a GridView control
	an. Drag a GridView control onto the page and drop it underneath the SqlDataSource control.

ao. In the “GridView Tasks” menu, select SqlDataSource1 from the “Choose Data Source” list to bind the GridView to the SqlDataSource.

ap. Use the “Auto Format” command in “GridView Tasks” to apply the “Rainy Day” format to the GridView.

aq. Click “Edit Columns” in the “GridView Tasks” Smart Tag.

ar. In the Selected fields list select the column named “price.” Set its DataFormatString property to “{0:c}”, its ItemStyle-HorizontalAlign property to Right, and its HtmlEncode property to False. Click OK. 

as. Click “Add New Column” in the “GridView Tasks” Smart Tag.

at. Select “CheckBoxField” in the Choose a field type list and fill in the remaining fields of the Add Field dialog as pictured below. Then click OK.
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au. Click “Edit Columns” in the “Common GridView Tasks” menu.

av. Select the “add to cart” column that you just added and click “Convert this field into a TemplateField.” Then set the column’s ItemStyle-HorizontalAlign property to Center and click OK.

aw. Check the “Enable Sorting” box in the “GridView Tasks” menu.

ax. Select the GridView in the designer and use the Properties window to set its Width property to 100%.
ay. Select “Start Without Debugging” from the Debug menu (or press Ctrl+F5) to launch Default.aspx in a browser window. Verify that the output looks something like this:
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az. Sort the GridView by clicking one of the sortable column headers. Also verify that clicking the same header several times in succession performs alternating ascending and descending sorts.

ba. Close the browser and return to Visual Studio.




Exercise 4
Build the check-out page

In this exercise, you’ll build a check-out page that lists the items selected in the GridView on the previous page and asks for a credit card number. You’ll see first-hand how cross-page postbacks work and how a page that’s the target of a cross-page postback can communicate with the page that posted to it. You’ll also build a simple component that validates credit card numbers and allow ASP.NET to autocompile it.

	Tasks
	Detailed Steps

	10. Add a content page


	bb. Right-click C:\..\Lab1 in Solution Explorer and select “Add New Item.”

bc. Select “Web Form” and name it CheckOut.aspx. Make sure the “Place code in separate file” and “Select master page” boxes are checked before clicking Add.

bd. Select Site.master as the master page.

be. Add the following directive below the Page Directive.

<%@ PreviousPageType VirtualPath="~/Default.aspx"  %>

bf. Click the Design button to switch to Design view.



	11. Add content to the page
	bg. Add a pair of text strings, a BulletedList control, a TextBox control, and a Button control to the page’s Content control, approximating the layout shown below. 

· The layout pictured here uses 14-point bold Verdana for the text strings and 12-point bold Verdana for the BulletedList control. Use the Formatting toolbar to set the font on the text strings, and the Properties window to set the font on the BulletedList. To set the font size to 12-point on the latter, you’ll need to type “12pt” into the Size box under Font.
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bh. Double-click the page in the designer to add a Page_Load method.

bi. Add the following code to Page_Load to bind the BulletedList to an ArrayList containing the titles of the books selected on the previous page. Note the use of the PreviousPage property to call a public method on the page that posted to this one:

C#

if (PreviousPage != null && PreviousPage.IsCrossPagePostBack)

{


BulletedList1.DataSource = ((_Default) PreviousPage).GetTitles ();


BulletedList1.DataBind ();

}

VB

If Not (PreviousPage Is Nothing) AndAlso _ 


PreviousPage.IsCrossPagePostBack Then


BulletedList1.DataSource = _ 



CType(PreviousPage, _Default).GetTitles


BulletedList1.DataBind

End If

bj. Double-click Default.aspx.cs or Default.aspx.vb in the Solution Explorer to open it for editing and add the following method to the Default_aspx class:

C#

public ArrayList GetTitles ()

{

  ArrayList list = new ArrayList ();

  foreach (GridViewRow row in GridView1.Rows) 

  {

    CheckBox box = 

     (CheckBox) row.Cells[3].Controls[1];

    if (box.Checked)

     list.Add (row.Cells[0].Text);

  }

  return list;

}

VB

Public Function GetTitles() As ArrayList

  Dim list As New ArrayList()

  For Each row As GridViewRow In GridView1.Rows

    Dim box As CheckBox = _

     CType(row.Cells(3).Controls(1), CheckBox)

    If box.Checked Then

      list.Add(row.Cells(0).Text)

    End If

  Next

  Return list

End Function

bk. Return to design view in Default.aspx.  

bl. Add a button below the GridView and set the  properties of Text to “Checkout >>” and PostBackURL to CheckOut.aspx:

bm. Click Default.aspx in the Solution Explorer window and press Ctrl+F5 to launch it.

bn. Check a few of the boxes in the GridView and click the Check Out button at the bottom of the page. Verify that CheckOut.aspx appears and accurately lists the items you selected:

bo. Close the browser and return to Visual Studio.



	12. Add a CreditCard component


	bp. In the Solution Explorer window, right click the App_Code folder and select “Add New Item.”

bq. Select “Class” as the template type and type “CreditCard” into the Name box. Because this source code file is located in the App_Code folder, it will be autocompiled by ASP.NET.

br. Add the following method to the CreditCard class. It “validates” a credit card number by ensuring that it’s 16 digits long:

C#

public static bool IsValid (string number)

{

  return (number.Length == 16) && 

    System.Text.RegularExpressions.Regex.IsMatch(

      number, "^(\\d{16})");

}


VB

Public Shared Function IsValid( _

 ByVal number As String) As Boolean

  Return (number.Length = 16 AndAlso _

   System.Text.RegularExpressions. _

   Regex.IsMatch(number, "^(\d{16})"))

End Function

bs. Go back to the designer and open CheckOut.aspx in Design view. Double-click the “Place Order” button to write a click handler for it.

bt. Add the following code to the Button1_Click method

C#

if (CreditCard.IsValid(TextBox1.Text))

  Response.Redirect("ThankYou.aspx"); 

else 

  ClientScript.RegisterStartupScript(

   script.GetType(),"Error", script);

VB

If CreditCard.IsValid(TextBox1.Text) Then

  Response.Redirect("ThankYou.aspx")

Else

  ClientScript.RegisterStartupScript( _

   script.GetType(),"Error", script)

End If

bu. Add the following field to the CheckOut_aspx class:

C#
static readonly string script =

  "<script language=\"javascript\">\n" +

  "alert (\"Sorry, but we couldn't validate your" +

  " credit card\");\n" +

  "</script>";

VB

Private Shared ReadOnly script As String = _

 "<script language=""javascript"">" & vbCrLf & _

 "alert (""Sorry, but we couldn't validate your" & _

 " credit card"");" & vbCrLf & "</script>"

bv. Select Default.aspx in the Solution Explorer window and press Ctrl+F5 to launch it. Select a few items in the GridView and click the Check Out button. Type “12345” into the credit card box and click “Place Order.” The following error message should appear in a popup message box.
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bw. Dismiss the message box. Then close the browser and return to Visual Studio.



Exercise 5
Build the thank-you page

All that remains now is to build the content page that the Place Order button redirects to following a successful credit card validation. In this exercise, you’ll build that page and then test the finished application..

	Tasks
	Detailed Steps

	13. Add a content page


	bx. Right-click C:\..\Lab1 in Solution Explorer and select “Add New Item.”

by. Select “Web Form” and name it ThankYou.aspx. Check the “Place code in separate file” and “Select master page” boxes before clicking Add.
bz. Select Site.master as the master page.

ca. Click the Design button to switch to Design view.

cb. Position the cursor in the page’s Content control and type “Thank you for using MSN Bookstore!”

cc. Modify the text you just typed to use a bold italic 14-point Verdana font.



	14. Test the finished application
	cd. Select Default.aspx in the Solution Explorer window and press Ctrl+F5 to launch it.

ce. Check a few of the boxes in the GridView and click the “Check Out” button.

cf. Type “1234567812345678” into the credit card box and click the “Place Order” button.

cg. Verify that ThankYou.aspx appears and displays the message shown below:
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ch. Close the browser and return to Visual Studio.




Exercise 6
Use the Web Site Administration Tool

Another of the new features in ASP.NET is the Web Site Administration Tool. In ASP.NET 1.x, you change configuration settings by hand-modifying CONFIG files. In ASP.NET 2.0, most configuration changes can be made through the Web Site Administration Tool. The tool is built on top of the new configuration API, which we’ll explore in detail in a subsequent course module.

In this exercise, you’ll use the Web Site Administration Tool to make a simple configuration change to your Web site.

	Tasks
	Detailed Steps

	15. Start the Web Site Administration Tool


	ci. Select “ASP.NET Configuration” from Visual Studio’s Website menu. After a brief pause, the following web page appears:
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· NOTE:

The “Website->ASP.NET Configuration” command launches the Web Site Administration Tool based upon the active project in the Visual Studio IDE. Outside Visual Studio, you can launch the Web Site Administration Tool by pointing your browser to http://.../webadmin.axd, where “...” targets a virtual directory containing an ASP.NET application. Webadmin.axd isn’t a file; it’s a phantom resource mapped to an HTTP handler that redirects to the Web Site Administration Tool on the Web server.



	16. Toggle the debug setting
	cj. Click the Application tab at the top of the page, or the “Application Configuration” link in the body of the page.

ck. Click “Configure debugging and tracing.”
cl. Back in Visual Studio, double-click C:\MSLabs\Web\Starter\<language>\Lab1\web.config in Solution Explorer to open the file. Read the <compilation> element and make a mental note of what it says.

cm. Return to the Web Site Administration Tool and click the “Enable debugging” box.

cn. Return to Visual Studio. A message informing you that Web.config has been modified outside the source editor and asks if you want to reload it. Click the “Yes” button.

co. In Web.config, how has the <compilation> element changed?

cp. Close the Web Site Administration tool and Visual Studio 2005.




An in-depth exploration of ASP.NET 2.0 (Part 1)

ASP.NET 2.0 Data Access

Access to back-end databases and other data stores is an important element of data-driven Web applications. ASP.NET 2.0 makes building data-driven pages easier than ever before by providing data controls such as GridView and DetailsView to render data into HTML, and data source controls such as SqlDataSource and ObjectDataSource to declaratively bind data controls to data sources. Thanks to these controls, data access chores that required hundreds of lines of code in ASP.NET 1.x can often be accomplished with little or no code in ASP.NET 2.0.

In this exercise, you’ll begin building a Web site named MyComics that serves as a virtual catalog for comic books. You’ll create a Web site to front the MyComics database and build a page that permits users to browse through the comic books in a GridView. Next, you’ll add a page that shows comic book details in a DetailsView. Finally, you’ll add an admin page that permits comic books to be inserted, updated, and deleted. In addition to learning how to create a Web site with Visual Studio and use the IDE to add pages, controls, and data components, you’ll get an in-depth look at SqlDataSource and ObjectDataSource controls and gain first-hand experience with the editing capabilities of GridView and DetailsView controls.

Once the pages are up and running, you’ll enable caching in the data source controls to maximize performance by minimizing database I/O. And to top things off, you’ll use SQL cache dependencies to ensure that you’re always serving up fresh data to your users—even if the underlying data changes.

Exercise 7
Verify the MyComics Database 

In this exercise, you’ll verify a SQL Server database named MyComics exists to serve as the application’s primary data store.

	Tasks
	Detailed Steps

	17. Connect to the database 
	cq. Start Visual Studio 2005 (or if started, close your previous project)

cr. In the Server Explorer window right click on Data Connections and select Add Connection.

If the Server Explorer window is not visible, select the View | Server Explorer menu item.

If the Change Data Source dialog appears, select Microsoft SQL Server and click OK. This will bring up the Add Connection dialog.

cs. In the Add Connection dialog, verify the Data source is Microsoft SQL Server (SqlClient). If a different provider is selected, choose the Change button to change the data source provider type.

ct. In the Add Connection dialog set the Connection Properties as follows: 

Server Name: localhost

Use Windows Authentication

Select or enter a database name: MyComics

cu. Press Test Connection
· If unable to connect and test; run the script C:\MSLabs\ASP.NET\LabFiles\Database\MyComics.cmd and try again.

cv. Once you have verified that you can connect to the database, choose OK to close the Add Connection dialog. 

cw. In the Server Explorer expand the MyComics connection.

cx. Next, expand the Tables node and confirm there is a Comics table. 


Exercise 8
Use SqlDataSource to populate a DropDownList 
In this exercise, you’ll create a new ASP.NET Web site with Visual Studio. Then you’ll add a DropDownList control to the page and use a SqlDataSource to populate it with the results of a database query.

	Tasks
	Detailed Steps

	18. Create a new Web site 


	cy. Start Microsoft Visual Studio.

cz. Select “New Web Site” from Visual Studio’s File menu.

da. In the New Web Site dialog, choose “Visual C#” or “Visual Basic” as the language and “ASP.NET Web Site” as the template type. Browse to or Type in “C:\MSLabs\ASP.NET\Starter\<language>\Lab2” into the Location box and click OK to create the Web site.

	19. Add a SqlDataSource 

	db. Click the Design button to switch to Design view.
dc. Drag a SqlDataSource control from the Toolbox onto the page.

dd. Click “Configure Data Source” in the “SqlDataSource Tasks” menu (see below).
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de. When the Configure Data Source dialog pops up, click the New Connection button.

df. In the Add Connection dialog make sure the Data source is Microsoft SQL Server (SqlClient), then type “localhost” into the “Server name” box and select “Use Windows Authentication.” Then select “MyComics” under “Select or enter a database name” and click OK.

dg. Make sure the new connection is selected in the “What data connection should your application use to connect to the database?” box. Then click Next.

dh. When asked if the connection string should be saved in the application configuration file, answer yes and confirm that “MyComicsConnectionString” is the connection string name. Then click Next to proceed.

di. In the ensuing dialog, check “Title” in the Columns box. Also check “Return only unique rows,” as shown below. Then click Next to proceed.
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dj. Click Finish to finish configuring the SqlDataSource.

dk. Look in Visual Studio’s Solution Explorer window and observe that a Web.config file has been added to the Web site. Double-click Web.config to open it. What do you see in the <connectionStrings> section?

dl. Close Web.config.

dm. Click the Source button to see a Source view of Default.aspx. Find the <asp:SqlDataSource> tag and look at its ConnectionString attribute. What do you see on the right side of the equals sign?

	20. Add a DropDownList
	dn. Switch back to Design view and drag a DropDownList control onto the page.
do. Click “Choose Data Source” in the “DropDownList Tasks” menu.

dp. Select SqlDataSource1 from the list of data sources and click OK.

dq. Check the “Enable AutoPostBack” box in the “DropDownList Tasks” menu.

dr. Select “Start Without Debugging” from Visual Studio’s Debug menu (or press Ctrl+F5) to run Default.aspx in your browser. Verify that the page contains a drop-down list containing the items shown below.
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ds. Close the browser and return to Visual Studio.


Exercise 9
Use ObjectDataSource to Populate a GridView 
In this exercise, you’ll add a GridView control to the page. Rather than use a SqlDataSource to populate the GridView, you’ll create a data component that interacts with the database and bind it to the GridView using an ObjectDataSource. In addition, you’ll parameterize the ObjectDataSource so that it passes the title selected in the DropDownList to the data component for use in a WHERE clause.

	Tasks
	Detailed Steps

	21. Add a data component 
	dt. Add a folder named “App_Code” to the Web site by right-clicking C:\..\Lab2 in Solution Explorer and selecting “Add ASP.NET Folder ->App_Code.”
du. Right-click the App_Code folder and select “Add New Item.”

dv. In the ensuing dialog, select “DataSet” as the template type and enter MyComics.xsd as the file name. Then click the Add button. After a brief pause, the TableAdapter Configuration Wizard appears.

dw. If MyComicsConnectionString (Web.config) appears in the list of existing connections, select it. Otherwise, click the New Connection button and create a new MyComics connection, and then select it under “Select or enter a database name.” Then click Next.

dx. On the “Choose a Command Type” page, select “Use SQL statements.” Then click Next.

dy. On the “Generate the SQL Statements” page, type “SELECT ComicID, Title, Number, Year, Grade, CGC, BookValue FROM Comics WHERE Title=@Title” into the box labeled “What data should be loaded into the table?” Do NOT click the Next button just yet.

dz. Click the Advanced Options button. In the ensuing dialog, check the “Generate Insert, Update, and Delete statements” box and verify the other two boxes are unchecked, as shown below. Then click OK followed by Next.
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ea. In the “Choose Methods to Generate” page uncheck Fill a DataTable. In the Return a DataTable section, change the method name to GetComicsByTitle as shown below. The wizard will now include in the data component a method (which uses the query you entered earlier to populate a DataTable) as well as methods for performing INSERTs, UPDATEs, and DELETEs.
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eb. Click Next, followed by Finish. The TableAdapter Configuration Wizard writes the configuration options you selected to MyComics.xsd. MyComics.xsd contains an XML schema describing a data component. At run-time, ASP.NET autocompiles strongly typed data components from XSD files. You don’t see the components since they’re not part of the project per se, but you do see a diagram of what’s in the XSD file in the Visual Studio designer, as pictured below.
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ec. Choose “Save All” from Visual Studio’s File menu to save changes.

	22. Add an ObjectDataSource 



	ed. Return to Default.aspx in the designer and drag an ObjectDataSource control onto the page.

ee. Click “Configure Data Source” in the “ObjectDataSource Tasks” menu.

ef. In the “Choose your business object” list select MyComicsTableAdapters.ComicsTableAdapter (the name of the data component that’s autocompiled from the XSD file you generated in the previous exercise). Then click Next.

eg. Make sure GetComicsByTitle is selected in the “Choose a method” list, as shown below. One by one, click the UPDATE, INSERT, and DELETE tabs and select “None” from their “Choose a method” lists. This will prevent Visual Studio from configuring the ObjectDataSource to support INSERTs, UPDATEs, and DELETEs. When you’re done, click Next.
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eh. Next you’re asked to specify a source for the GetComicsByTitle method’s Title parameter. Select Control in the “Parameter source” drop-down and DropDownList1 in the ControlID drop-down, as shown below. Then click Finish. 
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ei. Switch to Source view and examine the <asp:ObjectDataSource> element. What do you see there that creates a connection between the ObjectDataSource and the DropDownList?

	23. Add a GridView
	ej. Switch back to Design view and drag a GridView control onto Default.aspx. Insert a couple of line breaks to create some space between the GridView and the DropDownList.

ek. Click the arrow in the upper-right corner of the GridView to display the “GridView Tasks” menu and select ObjectDataSource1 as the GridView’s data source.

el. Use the “Auto Format” command in the “Common GridView Tasks” menu to apply the “Slate” format.

em. Select the GridView control in the designer. Then go to the Properties window and set the GridView’s Width property to 100%.

en. Press Ctrl+F5 to run Default.aspx. Verify that the output resembles that below, and that selecting a different title in the DropDownList changes the list of comics in the GridView. 
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eo. Close the browser and return to Visual Studio.

	24. Polish the GridView’s appearance
	ep. Open Default.aspx in Design view.

eq. Click the arrow in the upper-right corner of the GridView to display the “GridView Tasks” menu, and click “Edit Columns” to display the Fields dialog pictured below.
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er. Select “ComicID” in the “Selected Fields” box. In the property grid on the right, set ComicID’s HeaderText property to “Comic ID” and its Visible property to false.

es. Select the “Title” field. Set its SortExpression property to an empty string.

et. Select the “Number” field. Set its ItemStyle-HorizontalAlign property to “Center”.

eu. Select the “Year” field. Set its ItemStyle-HorizontalAlign property to “Center” and its SortExpression property to an empty string.

ev. Select the “Grade” field. Set its ItemStyle-HorizontalAlign property to “Center”. 

ew. Select the “CGC” field. Set its HeaderText property to “Certified?”, its ReadOnly property to true, its ItemStyle-HorizontalAlign property to “Center”, and its SortExpression property to an empty string.

ex. Select the “BookValue” field. Set its HeaderText property to “Value”, its DataFormatString property to “{0:c}”, its HtmlEncode property to “False”, and its ItemStyle-HorizontalAlign property to Right.

ey. Click OK to commit the changes and dismiss the Fields dialog.

ez. In the designer, display the GridView’s “GridView Tasks” menu again if it isn’t already displayed. Check the menu’s “Enable Sorting” box.

fa. Press Ctrl+F5 to Launch Default.aspx in your browser. Verify that the page resembles the one below. Also verify that you can sort by number, grade, and value, and that clicking the same sortable column header several times in a row performs alternating ascending and descending sorts. 
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fb. Close the browser and return to Visual Studio.


Exercise 10
Create a details page
In this exercise, you’ll add a page named Details.aspx to the Web site and embellish it with a DetailsView control. Then you’ll connect the two pages so that clicking an item in Default.aspx displays details about that item in Details.aspx.?

	Tasks
	Detailed Steps

	25. Add another page to the Web site
	fc. Right-click C:\..\Lab2 in Solution Explorer and select “Add New Item.”

fd. Select “Web Form” and name it Details.aspx. Be sure the “Place code in separate file” box is checked and that C# or Visual Basic is selected in the Language box before clicking the Add button.

	26. Add another data component


	fe. Double-click MyComics.xsd in the Solution Explorer window to open it for editing.

ff. Right-click the design surface and select “Add->TableAdapter” to display the TableAdapter Configuration Wizard. 

fg. Select “MyComicsConnectionString (Web.config)” in the data connections list and click Next. 

fh. On the “Choose a Command Type” page, select “Use SQL statements.” Then click Next.

fi. On the “Generate the SQL statements” page, type “SELECT * FROM Comics WHERE ComicID=@ComicID”. Then click the Advanced Options button and verify the “Use optimistic concurrency” and “Refresh the data table” boxes are unchecked. Click OK, followed by Next.

fj. Fill in the “Choose Methods to Generate” page as shown below. Note that the name typed into the “Method Name” box is GetComicDetails, not GetComicsByTitle.
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fk. Click Next, followed by Finish. Confirm that the new data component looks like this:
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fl. Right-click “Comics1TableAdapter” and use the Rename command to change the name to “DetailsTableAdapter”: 
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fm. Choose “Save All” from Visual Studio’s File menu to save changes.

	27. Add an ObjectDataSource
	fn. Return to the designer and open Details.aspx in Design view.

fo. Drag an ObjectDataSource control from the Toolbox and drop it onto the page.

fp. Click “Configure Data Source” in the “ObjectDataSource Tasks” menu.

fq. Under “Enter the name of your business object,” select MyComicsTableAdapters.DetailsTableAdapter. Then click Next.

fr. Make sure GetComicDetails in selected in the “Choose a method” list on the SELECT page. Select “None” in the “Choose a Method” list on the UPDATE, INSERT, and DELETE pages. Then click Next.

fs. Next you’re asked to specify a source for GetComicDetails’s ComicID parameter. Select QueryString in the “Parameter source” drop-down, type “ComicID” into the QueryStringField box, and type “0” into the DefaultValue box as shown below. Then click Finish. 
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ft. Switch to Source view and inspect the <asp:ObjectDataSource> element. What does the <SelectParameters> element inside it do?

	28. Add Select buttons to the GridView
	fu. Open Default.aspx in Design view.

fv. Select the GridView control and set its AutoGenerateSelectButton property to true.

fw. Press Ctrl+F5 to launch Default.aspx in your browser. What’s different about the GridView?

fx. Close the browser and return to Visual Studio.

fy. Select the GridView control.

fz. Click the lightning-bolt icon in the Properties window to display a list of GridView events.
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ga. Double-click “SelectedIndexChanged” to add a SelectedIndexChanged event handler to Default.aspx.cs or Default.aspx.vb.

gb. Add the following code to the body of the handler:

C#

Response.Redirect ("Details.aspx?ComicID=" + GridView1.SelectedValue);

VB

Response.Redirect("Details.aspx?ComicID=" & _ GridView1.SelectedValue.ToString)
gc. Return to Default.aspx. In the Properties window, click the button to the left of the lightning bolt to display properties instead of events.

gd. Select the GridView control and verify its DataKeyNames property is set to “ComicID” so GridView1.SelectedValue will return the value of the ComicID field in the row that’s currently selected.

ge. Press Ctrl+F5 to launch Default.aspx in your browser.

gf. Click one of the GridView’s Select buttons. What happens? What do you see in the browser’s address bar?

gg. Close the browser and return to Visual Studio.

	29. Add a DetailsView control
	gh. Open Details.aspx in Design view.

gi. Drag a DetailsView control from the Toolbox and drop it onto the page.

gj. Use the “DetailsView Tasks” menu to select ObjectDataSource1 as the DetailsView’s data source.

gk. Use the “Auto Format” command in the “DetailsView Tasks” menu to apply the format named “Slate.”

gl. Select the DetailsView control in the designer. Then go to the Properties window and set the DetailsView’s Width property to 100%.

gm. Select Default.aspx in the Solution Explorer window. Then press Ctrl+F5 to launch it.

gn. Click one of the GridView’s Select buttons and verify that Details.aspx appears showing details about the selected comic, as pictured below. 
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go. Close the browser and return to Visual Studio.

	30. Polish the DetailsView’s appearance
	gp. Open Details.aspx in Design view.

gq. Click the arrow in the upper-right corner of the DetailsView to display the “DetailsView Tasks” menu, and click “Edit Fields” to display the Fields dialog.

gr. Select “ComicID” in the “Selected Fields” box. Set its HeaderText property to “Comic ID”.

gs. Select “CGC” in the “Selected Fields” box. Sets its HeaderText property to “Certified?” and its ReadOnly property to true.

gt. Select “BookValue” in the “Selected Fields” box. Sets its HeaderText property to “Value”, its DataFormatString property to “{0:c}”, and its HtmlEncode property to “False”.

gu. Click OK to commit the changes and dismiss the Fields dialog.

gv. Select Default.aspx in the Solution Explorer window. Then press Ctrl+F5 to launch it.

gw. Click one of the GridView’s Select buttons and verify that the resulting DetailsView resembles the one below.
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gx. Close the browser and return to Visual Studio.


Exercise 11
Create an admin page
In this exercise, you’ll add a page named Admin.aspx to the Web site and populate it with an editable master-detail view for browsing, inserting, updating, and deleting records. You’ll use the data components you built in previous exercises to interact with the database, and you’ll use the editing features of the GridView and DetailsView controls and the 2-way data-binding support in ObjectDataSource to make short work of updating the database.

	Tasks
	Detailed Steps

	31. Add another page to the Web site
	gy. Right-click C:\..\Lab2 in Solution Explorer and select “Add New Item.”

gz. Select “Web Form” and name it Admin.aspx. Be sure the “Place code in separate file” box is checked and that C# or Visual Basic is selected in the Language box before clicking the Add button.

	32. Copy controls to the page


	ha. Open Default.aspx in Source view and copy everything between the <form id="form1" runat="server"> tag and the </form> tag to the clipboard.

hb. Open Admin.aspx in Source view and paste the contents of the clipboard between the <form id="form1" runat="server"> and </form> tags.

hc. If you are using C# clear the OnSelectedIndexChanged="GridView1_SelectedIndexChanged" portion of the <asp:GridView> tag.

hd. Open Details.aspx in Source view and copy everything between the <form id="form1" runat="server"> and </form> tags to the clipboard.

he. Go back to Admin.aspx in Source view and paste the contents of the clipboard immediately below the content you pasted in step 2.

hf. Click the Design button to show Admin.aspx in Design view. Insert a blank line between the GridView and the DetailsView to create some space between them. Here’s what Admin.aspx should look like in the designer:
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hg. Use the DetailsView’s “DetailsView Tasks” menu to set the DetailsView’s data source to ObjectDataSource2. If Visual Studio asks if you’d like the DetailsView’s field and keys refreshed, answer No.

hh. Select the GridView control. Then go to the properties window and set the GridView’s AutoGenerateDeleteButton property to true.

hi. Select the DetailsView control. Go to the properties window and set the DetailsView’s AutoGenerateEditButton and AutoGenerateInsertButton properties to true.

hj. Verify the DetailsView’s DataKeyNames property is set to “ComicID”.

hk. Display the DetailsView’s “DetailsView Tasks” menu and click “Edit Fields.” In the Fields dialog, set the “ComicID” field’s Visible property to False and the “Certified?” field’s ReadOnly property to False. Press OK. 

hl. Select ObjectDataSource2 and display its “ObjectDataSource Tasks” menu. Click “Configure Data Source” and then click Next until you reach the “Define parameters” page. ObjectDataSource2 is currently configured to acquire the ComicID parameter that it uses in database queries from a query string. Fill in the dialog as shown below to reconfigure ObjectDataSource2 to acquire the parameter from the GridView. Then click the Finish button. If Visual Studio offers to refresh the DetailsView control, answer No.
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hm. Press Ctrl+F5 to launch Admin.aspx in your browser. Confirm that clicking one of the GridView’s Select buttons displays details about the corresponding comic in a DetailsView, as shown below.
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hn. Close your browser and return to Visual Studio.

	33. Configure the ObjectDataSource controls to support 2-way data binding
	ho. Return to Admin.aspx in the designer. Select the “Configure Data Source” command from ObjectDataSource1’s “ObjectDataSource Tasks” menu. Click Next until you reach the “Define data methods” page.
hp. Set ObjectDataSource1’s SELECT and DELETE methods to GetComicsByTitle and Delete, respectively. (The DELETE setting is shown below.) Set its UPDATE and INSERT methods to “None” since this ObjectDataSource won’t be used to insert or update records. Then click Next, followed by Finish. If Visual Studio offers to refresh the GridView, answer No.
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hq. Select the “Configure Data Source” command from ObjectDataSource2’s “Common ObjectDataSource Tasks” menu. Click Next until you reach the “Define data methods” page.

hr. Set the ObjectDataSource2’s SELECT, UPDATE, and INSERT methods to GetComicDetails, Update, and Insert, respectively. Set its DELETE method to “None” since this ObjectDataSource won’t be used to delete records. Then click Next, followed by Finish. If Visual Studio offers to refresh the DetailsView, answer No.

hs. Select ObjectDataSource1 in the designer and click the lightning-bolt icon in the Properties window to display a list of ObjectDataSource events.

ht. Double-click “Deleted” in the Properties window to add a handler for ObjectDataSource1.Deleted events.

hu. Add the following statement to the body of the handler to ensure that the drop-down list of titles is updated if the last title in a category is deleted:

C#

DropDownList1.DataBind();

VB

DropDownList1.DataBind()
hv. Return to Admin.aspx and select ObjectDataSource2 in the designer.

hw. Go to the Properties window (which currently lists ObjectDataSource events) and double-click “Inserted” to add a handler for ObjectDataSource2.Inserted events.

hx. Add the following statement to the body of the handler to ensure that the GridView and the drop-down list are updated when a comic is added to the database:

C#

DropDownList1.DataBind();

GridView1.DataBind();

VB

DropDownList1.DataBind()
GridView1.DataBind()
hy. Return to Admin.aspx and select ObjectDataSource2 in the designer.

hz. Go to the Properties window (which currently lists ObjectDataSource events) and double-click “Updated” to add a handler for ObjectDataSource2.Updated events.

ia. Add the following statement to the body of the handler to ensure that the GridView is updated when a record is updated:

C#

GridView1.DataBind ();

VB

GridView1.DataBind()


	34. Test the admin page
	ib. Press Ctrl+F5 to launch Admin.aspx in your browser.
ic. Test the page’s record insertion capabilities by selecting one of the Captain Code comics in the GridView and clicking the New button in the DetailsView. Fill in the fields as follows:
Name

Value

Title

Captain Code

Number

8

Publisher

Microsoft

Year

2004

Grade

9.0

Certified?

Unchecked

Value

30

Comment

Introducing CodeGirl and her sidekick, CodeKid

id. Click “Insert” at the bottom of the DetailsView to insert the comic into the database. Verify that Captain Code 8 now appears in the GridView.

ie. Test the page’s record updating capabilities by selecting Captain Code 8 in the GridView and clicking “Edit” in the DetailsView. Change the grade in the Grade field from 9.0 to 7.0. Then click “Update.” Verify that the grade changes to 7.0 in the GridView.

if. Test the page’s record deletion capabilities by clicking the Delete button next to Captain Code 8 in the GridView. Verify that the record disappears from view.

ig. Close your browser and return to Visual Studio.


Exercise 12
Add caching and cache dependencies

Database queries are expensive—especially if they return images or other large objects. Performance problems are compounded if queries target remote database servers. The solution to the problem of performance-inhibiting database queries is caching, which ASP.NET 2.0 provides robust support for. In this exercise, you’ll enable caching in Default.aspx and Details.aspx’s data source controls to minimize redundant database accesses. Then you’ll use SQL cache dependencies to prevent caching from causing users to see outdated data.

	Tasks
	Detailed Steps

	35. Enable caching in the data sources


	ih. Open Default.aspx in Design view. Select SqlDataSource1 and use the Properties window to set its EnableCaching property to True and its CacheDuration property to 300 (that’s 300 seconds, or 5 minutes).

ii. Set ObjectDataSource1’s EnableCaching property to True and its CacheDuration property to 300.

ij. Open Details.aspx in Design view. Set ObjectDataSource1’s EnableCaching property to True and its CacheDuration property to 300.

ik. Run Default.aspx and make sure it works as before. Leave Default.aspx running in the browser with .NET Man selected in the DropDownList.

il. Use Server Explorer to change the grade assigned to .NET Man 1 from 9.0 to 2.0. (You can open a table for editing in Server Explorer by drilling down into the MyComics connection to the Comics Table, right click and select “Show Table Data.”)

im. Refresh Default.aspx in the browser. What grade is shown for .NET Man 1? Is it 2.0 or 9.0? Why?

in. Close the browser and return to Visual Studio.

	36. Configure the database for SQL cache dependencies


	io. Open a Visual Studio command prompt window. You’ll find it under “All Programs->Microsoft Visual Studio 2005 ->Visual Studio Tools->Visual Studio Command Prompt.”

ip. Type aspnet_regsql -S localhost -E -d MyComics –ed to configure the MyComics database to support SQL cache dependencies.

iq. Type aspnet_regsql -S localhost -E -d MyComics -t Comics –et to configure the Comics table to support SQL cache dependencies.

ir. Go to Server Explorer and refresh the list of tables in the MyComics database. A new table has appeared. What is its name?

is. Use Server Explorer to view the triggers attached to the Comics table. (You can view a table’s triggers by drilling into the table and viewing the objects with a lightning bolt next to them) There should be a trigger named Comics_AspNet_SqlCacheNotification_Trigger. What does the trigger do?

it. Return to Solution Explorer and open Web.config. Add the following statements to the <system.web> section:

<caching>

<sqlCacheDependency enabled="true" pollTime="5000">

<databases>

<add name="MyComics" connectionStringName="MyComicsConnectionString" />

</databases>

</sqlCacheDependency>

</caching>

iu. Close Web.config, saving your changes, and return to the designer.

	37. Add SQL cache dependencies to the data sources
	iv. In Default.aspx, set SqlDataSource1's SqlCacheDependency property to "MyComics:Comics”.

iw. In Default.aspx, set ObjectDataSource1's SqlCacheDependency property to "MyComics:Comics”.

ix. In Details.aspx, set ObjectDataSource1's SqlCacheDependency property to "MyComics:Comics”.

iy. Run the application and make sure Default.aspx and Details.aspx work as they did before. Leave Default.aspx running with .NET Man selected in the DropDownList.

iz. Use Server Explorer to change .NET Man 1’s grade from 2.0 to 6.0. 

ja. Wait a few seconds, and then refresh Default.aspx in the browser. What grade is shown for .NET Man 1? Why?

	38. Monitor database activity on the back end (optional)
	jb. Start the SQL Server Profiler (All Programs->Microsoft SQL Server 2005->Performance Tools-> SQL Server Profiler).

jc. Use Profiler’s File->New Trace command to start a new trace. (Click Connect in the first dialog and Run in the second one to start the trace running.)

jd. Launch Default.aspx in your browser and refresh the page several times, watching the trace window in Profiler as you do. Is the database queried anew each time the page refreshes?


An in-depth exploration of ASP.NET 2.0 (Part 1)

Optional LAB

ASP.NET 2.0 User Interface Enhancements: Master Pages, Themes, and Controls 

ASP.NET 2.0 provides a wide range of new features to simplify the development of user interfaces, from master pages, themes, and skins to more than 50 new controls designed to make short work of implementing common user interface elements.

In this lab, you’ll get first-hand experience using these new features by giving the MyComics application a face-lift. First, you’ll add a master page to the site. Next, you’ll theme the site using a custom theme. Finally, you’ll use a MultiView control to offers users a choice of ways to view comic book data, and you’ll combine DataList controls and custom HTTP handlers to implement a new view of the comic database.

Exercise 13
Create a master page

In this exercise, you’ll create a master page to serve Default.aspx, Details.aspx, Admin.aspx, and other pages that will be added later. Then you’ll modify the existing pages by turning them into content pages..

	Tasks
	Detailed Steps

	39. Open the Web site
	je. Start Microsoft Visual Studio 2005 and use the “File->Open Web Site” command to open the C:\MSLabs\ASP.NET\Starter\<Language>\Lab3 site.

jf. Right-click C:\..\Lab3 in the Solution Explorer window and select “New Folder.”  Name the folder Images.

jg. Right-click the Images folder in Solution Explorer and use the “Add Existing Item” command to add MyComics.gif to the Images folder. You’ll find MyComics.gif in C:\MSLabs\ASP.NET\LabFiles\Images.



	40. Add a master page to the site


	jh. Right-click C:\..\Lab3 in Solution Explorer and select “Add New Item.”

ji. Choose “Master Page” as the template type and name the master page Site.master. Be sure C# or Visual Basic is selected in the Language box and that “Place code in separate file” is checked before clicking Add.

jj. Make sure Internet Explorer 6.0 is selected in the Target Schema for Validation drop-down list in the toolbar. 

jk. Click the Design button to switch to Design view.

	41. Define the layout of the master page
	jl. Select “Insert Table” from Visual Studio’s Layout menu.

jm. In the Insert Table dialog click the Template button and select “Header, footer, and side” from the drop-down list as shown below. Then click OK to add a table to the master page.
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jn. Grab the ContentPlaceHolder control by the title bar and move it into the right-hand cell of the table’s second row.

jo. Place the cursor in that cell (not in the ContentPlaceHolder). Then go to the Properties window and set the cell’s VAlign property to “top”. The ContentPlaceHolder control should snap to the top of the cell 

jp. Right-click the table’s top row and select “Insert->Row Below” from the context menu.

jq. Select the new row. Then set its Height to 1 and BgColor to Gray.

jr. Right-click the table’s bottom row and select “Insert->Row Above” from the context menu.

js. Select the new row. Then set its Height to 1 and BgColor to Gray.

jt. Right-click the cell to the left of the one that contains the ContentPlaceHolder control and select “Insert->Column to the Right.”

ju. Put the cursor in the new cell. Then set the cell’s Width to 1 and BgColor to Gray.

jv. Select the table’s top row. Set BgColor to “#105070”.

jw. Put the cursor in the leftmost cell in the table’s middle row. Set BgColor to “#ececec.”

jx. Select the table’s bottom row. Set BgColor to “#ececec”.

jy. Switch to Source view and manually modify the <body> tag to look like this:

<body topmargin="0" bottommargin="0" leftmargin="0" rightmargin="0">
jz. Click the Design button to view the master page in Design view. It 

should look something like this:
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	42. Add content to the master page
	ka. Drag a HyperLink control from the Toolbox and drop it into the top row of the table.

kb. Set the HyperLink’s ImageUrl property to “~/Images/MyComics.gif” and its NavigateUrl property to “~/Default.aspx”.

kc. Select the table’s top row. Set its Height property to 1 so the height will adjust to fit the image.

kd. Put the cursor in the leftmost cell in the table’s middle row. Set the cell’s Width property to 128.

ke. Select the table’s bottom row. Set its Height property to 16.

kf. With the cursor still in the bottom row, set the font to 8-point Verdana and type “If this page works, I built it. If it doesn’t work, I don’t know who built it.” The master page should now look like this in the designer:
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	43. Convert existing pages into content pages
	kg. Double-click Default.aspx in Solution Explorer to open it in the designer.

kh. Switch to Source view and add a MasterPageFile="~/Site.master" attribute to the @ Page directive at the top of the page.

ki. Also in Source view, remove the <!DOCTYPE>, <html>, <head>, <body>, <form>, and <div> elements from the page. Then add an <asp:Content> element that encapsulates all of the page’s remaining content:

<asp:Content ID="Content1" ContentPlaceHolderID="ContentPlaceHolder1" Runat="server">

</asp:Content>
kj. Add a Title=“MyComics” attribute to Default.aspx’s @ Page directive.

kk. Repeat steps a through d for Details.aspx so that it, too, becomes a content page.

kl. Repeat steps a through d for Admin.aspx so that it, too, becomes a content page.

km. Select Default.aspx in the Solution Explorer window. Then press Ctrl+F5 to launch it.

kn. Verify that Default.aspx was successfully converted into a content page:
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ko. Click one of the GridView’s Select buttons to display Details.aspx. Verify that it, too, was successfully converted into a content page.

kp. Change the URL in browser’s address bar to point to Admin.aspx and verify that it, too, is now a content page.

kq. Close the browser and return to Visual Studio.

	44. Refine Default.aspx
	kr. Open Default.aspx in the designer and switch to Design view.

ks. Position the cursor underneath the GridView control and use the “Layout->Insert Table” command to insert a table. In the Insert Table dialog, select the Header template shown below. Click OK. 
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kt. Drag the existing SqlDataSource and DropDownList controls into the table’s top row.

ku. Drag the existing ObjectDataSource and GridView controls into the table’s bottom row.

kv. Delete any whitespace between the table’s top row and the top of the page so the top of the table lines up with the top of the page.

kw. Right-click the top row of the table and select “Insert->Row Below.”

kx. Set the new row’s height to 1 and background color (BgColor) to Gray.

ky. Set the top row’s height to 32 and background color to “#ececec”.

kz. Insert a space or two to the left of the DropDownList to move it away from the left border of the table cell.

la. Select the DropDownList. Then go to the Properties window and set the font to 10-point Verdana.

lb. Set the GridView control’s font to 10-point Verdana also.

lc. Press Ctrl+F5 to launch Default.aspx in your browser and verify that it resembles the page pictured below:
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ld. Close the browser and return to Visual Studio.



	45. Refine Details.aspx
	le. Open Details.aspx in Design view.

lf. Set the DetailsView control’s font to 10-point Verdana.



	46. Refine Admin.aspx
	lg. Open Admin.aspx in Design view.

lh. Repeat the steps you performed on Default.aspx in Task 6 for Admin.aspx. As an alternative, you can cut-and-paste the HTML added to Default.aspx in Task 6 into Admin.aspx.

li. Set the DetailsView control’s font to 10-point Verdana.




Exercise 14
Theme the Web site’s pages 

Theming is an easy-to-use mechanism for applying visual attributes en masse to controls. You can apply themes to individual pages or to an entire site. In this exercise, you’ll apply a supplied theme to see the effect it has on the site’s pages. Then you’ll customize the theme and use it to standardize MyComics’ look and feel.

	Tasks
	Detailed Steps

	47. Remove formatting from the GridView. 


	lj. Open Default.aspx in Design view. Select the GridView control and click the small arrow in its upper right corner to display the “GridView Tasks” menu.

lk. Click “Auto Format” and use the “Remove Formatting” option to remove the formatting you applied in Lab 2.

ll. Run Default.aspx in your browser. What does the GridView look like now?

lm. Close the browser and return to Visual Studio.



	48. Theme the page “BasicBlue”

	ln. Add a folder named “App_Themes” to the Web site by right-clicking C:\..\Lab3 in Solution Explorer and selecting “Add ASP.NET Folder ->Theme.
lo. Name the folder that is automatically created to “BasicBlue”.

lp. Right-click the App_Themes\BasicBlue folder in Solution Explorer and select “Add Existing Item.”

lq. Select C:\MSLabs\ASP.NET\LabFiles\Themes\BasicBlue\BasicBlue.skin to create a local copy of that file in your site’s App_Themes\BasicBlue folder.

lr. Add a folder named “Images” to the App_Themes \BasicBlue folder.

ls. Right-click the App_Themes\BasicBlue\Images folder in Solution Explorer and select “Add Existing Item.”

lt. Select all the files in C:\MSLabs\ASP.NET\LabFiles\Themes\BasicBlue\Images folder to create local copies of those files in your site’s App_Themes \BasicBlue\Images folder

lu. Open Default.aspx in Source view and add a Theme=”BasicBlue” attribute to the @ Page directive.

lv. Run Default.aspx in your browser. The page should look like this, with alternating rows in the grid a different color:
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lw. Close the browser and return to Visual Studio.

	49. Develop a theme of your own
	lx. Right-click the App_Themes folder and select Add ASP.NET Folder ->Theme. Name the folder MyComics.

ly. Right-click the App_Themes\MyComics folder in Solution Explorer and select “Add Existing Item.”

lz. Select BasicBlue.skin from your site’s own Themes\BasicBlue folder to create a local copy of that file in Themes\MyComics.

ma. Rename the file “MyComics.skin”.

mb. Double-click MyComics.skin in the Solution Explorer window.

mc. Use Visual Studio’s “Edit->Find and Replace->Quick Replace” command to replace all occurrences of “#000066” with “#105070”.

md. Now replace all occurrences of “#eeeeee” with “lightyellow”.

me. Close the Quick Replace window and save the modified file .

mf. Add a folder named “Images” to the Themes\MyComics folder.

mg. Right-click the Themes\MyComics\Images folder in Solution Explorer and select “Add Existing Item.”

mh. Select all the files in your own site’s Themes\BasicBlue\Images folder to create local copies of those files in Themes\MyComics\Images.

mi. Change the Theme attribute in Default.aspx’s @ Page directive to Theme=“MyComics.”

mj. Launch Default.aspx in your browser and note the changes in the controls.

mk. Close the browser and return to Visual Studio.



	50. Theme all the site’s pages
	ml. Open Default.aspx in Source view and remove the Theme attribute from the @ Page directive.

mm. Open Details.aspx in Design view.

mn. Select the DetailsView control and use the “Auto Format” command in the “DetailsView Tasks” menu to remove formatting from the DetailsView.

mo. Open Admin.aspx in Design view.

mp. Remove formatting from Admin.aspx’s GridView and DetailsView controls.

mq. Double-click Web.config in Solution Explorer to open it for editing.

mr. Add the following statement to the <system.web> section of Web.config:

<pages theme="MyComics" />

ms. Close web.config and save your changes. 

mt. Launch Default.aspx in your browser and verify that it’s still themed “MyComics.”

mu. Click one of the Select buttons to display Details.aspx. Verify that Details.aspx is themed to match Default.aspx.

mv. Change the URL in browser’s address bar to point to Admin.aspx and verify that Admin.aspx is themed as well.

mw. Close the browser and return to Visual Studio.




Exercise 15
Add multiple views

In this exercise, you’ll add a MultiView control to Default.aspx and populate the MultiView with two views: one that presents page content the way it’s presented now, and another that uses DataList controls to present page content in a completely different way. The DataList will use a custom HTTP handler named ImageGrabber.ashx to retrieve cover images from the database and render them to the page. You’ll also add buttons for switching between the views..

	Tasks
	Detailed Steps

	51. Add a custom HTTP handler


	mx. Right-click the c:\..\Lab3 folder in Solution Explorer and use the “Add Existing Item” command to make a local copy of the file C:\MSLabs\ASP.NET\LabFiles\Components\ImageGrabber.ashx.

my. Open ImageGrabber.ashx and inspect the code contained therein. It contains a dynamically compiled HTTP handler that reads a comic book ID from a query string and uses it to query the MyComics database for a comic book cover image. To improve performance, it caches cover images in the ASP.NET application cache, and it uses SqlCacheDependency objects to refresh cached cover images if the images in the database change. In a moment, you’ll use ImageGrabber.ashx as the target of ASP.NET Image controls to retrieve comic book cover images from the database and display them.



	52. Add a MultiView control to Default.aspx.


	mz. Open Default.aspx in Design view.

na. Grab a MultiView control from the Toolbox and drop it onto the page immediately below the GridView1.

nb. Drag a View control from the Toolbox and drop it into the MultiView. That view becomes View1.

nc. Drag the GridView1 control on the page into View1. 

· Do not drag a new GridView onto the page. You are just moving the GridView to View1. 

nd. Drag another View control from the Toolbox and drop it into the MultiView. That view becomes View2.

ne. Set the MultiView’s ActiveViewIndex property to 0.




Continued

	Tasks
	Detailed Steps

	53. Add a DataList control to the MultiView

	nf. Drag a DataList control from the Toolbox and drop it into View2.

ng. Use the “DataList Tasks” menu to assign ObjectDataSource1 as the DataLists’s data source. Upon completion, the page appears this way in the designer:

[image: image38.png]<

Content - Content1 (Custom)

- sabataSource1

[batabound ~|
o —— ———————————

[ObjectDatasource - ObjectDatasource1

MultiView1
View1

i Title  Number Year  Grade Certified? Value
Select Databound Databound Databound Databound ¥ Databour
Select Databound Databound Databound Databound ¥ Databour
Select Databound Databound Databound Databound ¥ Databour
Select Databound Databound Databound Databound ¥ Databour
Select Databound Databound Databound Databound  [#  Databour
o View2 -
bataList -Datalist1 =
Right.cickor chiose the Edt Tempiates task to edit tenplate content.
The ItemTemplate i requied.

T Desan | @ Source | [{][<18>] [<aspimultview#multvient | [<asprview#views>| [<asp-dataitedatais] ]





nh. Switch to Source view and add the following <ItemTemplate> to the DataList. Note the use of Image controls whose ImageUrl attributes point to ImageGrabber.ashx to render images from the database, and the simplified data-binding expressions that make HTML templates more readable:

C#

<ItemTemplate>

<table cellpadding="4">

<tr>

<td width="100">

<asp:Image ID="CoverImage"

ImageUrl='<%# "~/ImageGrabber.ashx?ComicID=" + Eval ("ComicID") %>'

Runat="server" />

</td>

<td valign="top" style="font-family: Verdana; font-size: 10pt">

<asp:Label ID="ComicID" Text='<%# Eval ("ComicID") %>'

Visible="false" Runat="server" />

<asp:LinkButton Text='<%# Eval ("Title") + "&nbsp;" 

+ Eval ("Number") %>' Runat="server" /><br />

<%# (bool) Eval ("CGC") ? "CGC " : "" %>

<%# Eval ("Grade", "{0:f1}") %>

</td>

</tr>

</table>

</ItemTemplate>


Visual Basic

<ItemTemplate>

<table cellpadding="4">

<tr>

<td width="100">

<asp:Image ID="CoverImage"

ImageUrl='<%# "~/ImageGrabber.ashx?ComicID=" & Eval("ComicID") %>'

Runat="server" />

</td>

<td valign="top" style="font-family: Verdana; font-size: 10pt">

<asp:Label ID="ComicID" Text='<%# Eval("ComicID") %>'

Visible="false" Runat="server" />

<asp:LinkButton Text='<%# Eval("Title") & "&nbsp;" & Eval("Number") %>'

Runat="server" /><br />

<%#IIf(Eval("CGC"), "CGC ", "")%>

<%#Eval("Grade", "{0:f1}") %>

</td>

</tr>

</table>

</ItemTemplate>

ni. Switch back to Design view and set the DataList’s RepeatColumns property to 3 to divide the output into 3 columns.

nj. Set the DataList’s RepeatDirection property to “Horizontal” to organize items in row-first (rather than column-first) order.

nk. Set the DataList’s CellPadding property to 8.

nl. Set the DataList’s EnableTheming property to False.

nm. With the DataList selected in Design view, click the lightning bolt icon in the Properties window to display a list a DataList events. Double-click “ItemCommand” to add an ItemCommand event handler to Default.aspx.cs or Default.aspx.vb.

nn. Add the following statements to the body of the handler:

C#

Label label = (Label) e.Item.FindControl ("ComicID");

Response.Redirect ("Details.aspx?ComicID=" + label.Text);

Visual Basic

Dim lbl As Label = _

   CType(e.Item.FindControl("ComicID"), Label)

Response.Redirect("Details.aspx?ComicID=" & lbl.Text)

no. Press Ctrl+F5 to launch Default.aspx. The page looks the same as it did before. In other words, the GridView is displayed, not the DataList. Why?

np. Close the browser and return to Visual Studio. Change the MultiView control’s ActiveViewIndex property to 1.

nq. Press Ctrl+F5 again. Verify that the resulting page looks like this:
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nr. Click one of the comic book titles and verify that Details.aspx appears showing details for that comic.

ns. Close the browser and return to Visual Studio.



	54. Add buttons for switching views
	nt. The next task is to add a pair of buttons for switching views interactively. Begin by setting the MultiView’s ActiveViewIndex property back to 0.

nu. Add a Button control to Default.aspx, positioning it just right of the DropDownList. Add a few spaces to separate the DropDownList and the Button. Then assign the Button control the following property values:

Text = "GridView"

EnableTheming = false

Width = 100

nv. Add another Button control to the page, positioning it just right of the button added in the previous step. Insert a few spaces between buttons to separate them. Then assign the new Button control the following property values:

Text = "DataList"

EnableTheming = False

Width = 100

nw. Double-click the “GridView” button to add a click handler. Add the following statement to the body of the handler:

C#

MultiView1.ActiveViewIndex = 0;

Visual Basic

MultiView1.ActiveViewIndex = 0

nx. Go back to Default.aspx in Design view and double-click the “DataList” button to add a click handler. Add the following statement to the body of the handler:

C#

MultiView1.ActiveViewIndex = 1;

Visual Basic

MultiView1.ActiveViewIndex = 1

If the buttons were defined inside the MultiView, you could implement view switching declaratively by setting the buttons’ CommandName properties to “SwitchViewByIndex” or “SwitchViewByID” and setting each button’s CommandArgument property to the corresponding view ID or view index. However, since the layout of this page calls for the buttons to be defined outside the MultiView, you have to write two lines of code—one per button—to perform view switching.

ny. Run Default.aspx in your browser and verify that you can switch views by clicking buttons. Here’s what the page looks like when “DataList” view is selected:
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You might have to select a title from the drop-down list after clicking the “DataList” button for the first time to get the comics to appear. Also, you may find that the title selected in the drop-down list gets out of sync with the titles shown on the page as you switch back and forth between views.










